Could not fetch model of type 'EclipseProject' using Gradle distribution

Could not fetch model of type 'EclipseProject' using Gradle distribution " http://services.gradle.org/distributions/gradle-1.10-bin.zip"

나는 현재 신규 프로젝트를 Gradle로 빌드하고 있다.

이클립스는 STS를 사용중인데, 다른 프로젝트를 임포트하고 신규 프로젝트를 생성하는 과정에서 JBoss가 필요하여 마켓에서 JBoss 플러그인을 설치하였다.


그런데 이전 프로젝트의 Gradle 빌드를 실행하려고 하니 위와 같은 에러가 발생하였다.


자세한 에러도 안 나오고, 네이버는 당연히 안 나오고 Google에서 검색하니 그나마 비슷한 사항이 나오기는 하나 해결책은 나오지 않는다. 맨붕이 오고 어떻게 해결할지는 모르겠고 자세한 로그도 없고

정말 STS 재설치해서 할까 고민했다.


고민 중에 아무래도 이클립스 플러그인 설치 후에 발생했다는 점과 오류 내용이 이클립스에서 Gradle 툴과 연관이 있지 않을까 싶었다.


그래서 마켓에서 내가 사용중이던 "Gradle IDE Pack"을 업데이트 해주었다.


다행히 문제 해결!!!!!!


같은 문제를 겪는 사람이 있다면 도움이 되길 바란다.

휴우..





Leave a Comment


to Top